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1. ES449 Overview 
 
The MSP430F44x Evaluation System (ES449) allows convenient prototyping of low-
power handheld LCD projects.  Refer to documentation from Texas Instruments for 
detailed information for the MSP430F44x variants.   
 
1.1 Features 
 
The key features of this product are: 
 
• Texas Instruments MSP430F449 flash processor 
• Our custom 7 digit 3v 4-mux LCD (SBLCDA2) 
• Texas Instruments RS232 interface using the MAX3221 
• Adjustable TPS7201 LDO for bench top use 
• Single-cell AAA 3.3v power supply based on the TPS60310 
• 3.3v CR2032 coin cell supply using the TPS60212 
• JTAG programming header 
• Bootloader header 
• 2 user LEDs 
• 2 user switches 
• Each MSP port pin exposed at IDC headers 
• Large prototyping area 
• 2Mbit serial flash (not populated on some early models) for data logging applications 
 
 
1.2 Frequently Asked Questions 
 
Our website contains up-to-date information on all our products, including Frequently 
Asked Questions at the bottom of each product page.  Please visit our website to review 
the Frequently Asked Questions for this and all our products if you encounter difficulty 
not addressed in this manual. 
 
 
1.3 Laboratory Manual 
 
In addition to this User Guide, we also offer a laboratory manual for this product for 
separate purchase.  The last chapter of this User Guide is a preview of the Laboratory 
Manual.  The table of contents and the first chapter of the Laboratory Manual are also 
available on the webpage for this product. 
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1.4 Notation  
 
Throughout SoftBaugh documentation, we follow a standard convention to identify 
boards, jumpers, other components, and pins. 
 
1.4.1 Boards, Components and Pins 
 
The following notation is used to identify boards, components, and pins: 
 
Board:Component.Pin 
 
Example: 
 
ES449:J12.5 identifies the bootloader header ground pin on the ES449. 
 
Where obvious from the context, the Board: portion may be omitted.  If an entire 
component rather than a single pin is being identified, then the .Pin portion is omitted. 
 
 
1.4.2 Jumpers 
 
Unless otherwise noted, pin 1 on a jumper is always square (observed from 
underneath), and the silkscreen designator for the jumper is near pin 1.  Where 
ambiguity could exist, a small '1' is placed near pin 1.  Pins are numbered across the 
short axis of the jumper first, and then down the long axis. 
 
Jumper settings are indicated by the following notation: 
 
Jumper.Pin-Pin 
Jumper.Open 
 
Example: 
 
J20.1-2 
 
A jumper block is to be placed across pin 1 and pin 2 on J20. 
 
In the special case of two-pin jumpers, such as those used to route power or measure 
current, the entire jumper may be treated as a SPST switch, and "opened". 
 
Example: 
 
J18.Open 
 
J18 is left open, with no jumper block.  In other sources this is referred to as "hanging" 
the jumper. 
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2. Board Options 
 
The ES449 allows many different user configurations set via jumpers, resistors, and 
testpoint options. 
 
 
2.1 Jumper Options 
 
The ES449 contains the following jumper-selected options: 
 
 

 
Figure 2-1 ES449 Jumper Options 

2.1.1 J1 
  
Port 1 of the MSP430 microcontroller 
 
 
2.1.2 J2 
 
Port 2 of the MSP430 microcontroller 
 
 
2.1.3 J3 
 
Port 3 of the MSP430 microcontroller 
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2.1.4 J4 
 
UART1 of the MSP430 microcontroller 
 

Table 2-1 ES449 J4 
 Pin Usage 

1 General purpose I/O / Transmit data out—UART mode 
2 General purpose I/O / Receive data in—UART mode 

 
 
 
 
 
2.1.5 J6  
 
Port 6 of the MSP430 microcontroller 
 
 
2.1.6 J7 
 
Power jack, see section 3 
 
 
2.1.7 J8 
  
Power terminal, see section 3 
 

Table 2-2 ES449 J8 
 Pin Usage 

1 Voltage input (+)  3.6v DC to 9.0v, no transients above 9.1v DC 
2 Ground (-) 

 
 
 
 
 
2.1.8 J9 
 
Input/Output header A 
 

Table 2-3 ES449 J9 
 Pin Usage 

1 Switch 1 output—Normally Vcc, when pressed equals ground (0v) 
2 Ground 
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2.1.9 J10 
 
Input/Output header B 
 

Table 2-4 ES449 J10 
 Pin Usage 

1 P1.0/ D1—Drive low to illuminate D1.  Remove R33 to disconnect 
from P1.0 

2 D2—Drive low to illuminate 
3 Switch 2 output-- Normally Vcc, when pressed equals ground (0v) 
4 Ground 

 
 
 
 
 
 
 
 
2.1.10 J11 
 
JTAG header 
 
 
2.1.11 J12 
 
Bootloader, see section 5 
 

Table 2-5 ES449 J12 
 Pin Usage 

1 BSLTX 
2 TCK 
3 BSLRX 
4 RST 
5 GND 
6 VCC 
7 TEST 
8 NC 
9 BLPWOFF 
10 BLTGTSIG 
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2.1.12 J13 
 
RS232 power options for the MAX3221.  See Texas Instruments MAX3221datasheet for 
details (SLLS348G) 
  

Table 2-6 ES449 J13 

Pin Usage 
1 U1:10 /INVALID:  
2 U1:1 /EN 
3 U1:16 /FORCEOFF 
4 U1:12 FORCEON 

 
 
2.1.13 J14 
 
RS232 DB9S connector 
 

Table 2-7 ES449 J14 
 Pin Usage 

1 NC 
2 Data transmit 
3 Data receive 
4 NC 
5 Ground 
6 NC 
7 NC 
8 NC 
9 NC 

 
 
 
 
 
 
 
 
 
 
 
 
2.1.14 J15 
 
RS232 power, jumper to power RS232 
 
 
2.1.15 J16 
 
Serial flash power, jumper to power serial flash 
 
 
2.1.16 J17 
 
MSP430 microcontroller power, jumper to power MSP430 microcontroller 
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2.1.17 J18 
 
AAA battery jumper, jumper to connect the AAA battery to U4 
 
 
2.1.18 J19 
 
Coin cell jumper, jumper to connect the coin cell to U2 
 
 
2.1.19 J20 
 
Power option header, see section 3 
 
 
2.1.20 J21 
 
Communication configuration header 

 
UART0 

 
 
 

1 2 
3 4 
5 6 

 
UART0 Loopback 

1 2
3 4
5 6 

 
UART1 

1 2 
3 4 
5 6 

 
 UART1 Loopback 

1 2
3 4
5 6

 
No Communication 

1 2 
3 4 
5 6 

 
Both UARTS Loopback 

1 2
3 4
5 6

Figure 2-2 ES449 J21 
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2.1.21 J22 
 
Serial flash isolation  

 
Serial Flash Connected 

 
 
 
 
 

1 2 
3 4 
5 6 
7 8 

 
Serial Flash Isolated 

 
 
 
 
 
 

1 2 
3 4 
5 6 
7 8 

Figure 2-3 ES449 J22 
 
 
2.1.22 J23 
 
LCD Character Select 

 
Select Character Seven 

 
1 2 3 
4 5 6 
7 8 9 

10 11 12 
13 14 15 
16 17 18 

 
Select Progress Bar  

1 2 3 
4 5 6 
7 8 9 

10 11 12 
13 14 15 
16 17 18 

Figure 2-4 ES449 J23 
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2.2 Test Points 
 

 
Figure 2-5 ES449 Test Points 

 
 

Table 2-8 ES449 Test Points 

Test Point (TP) Usage 
1 MAX3221 (U1) VCC 
2 Ground 
3 Ground 
4 Ground 
5 TPS7201 (U3) Output VLab 
6 TPS7201 (U3) PG  
7 TPS7201 (U3) /EN  
8 TPS60212 (U2) /SNOOZE 
9 TPS60310 (U4) /SNOOZE 

10 TPS60310 (U4) PG 
11 TPS60310 (U4) output voltage 1 
12 AAA battery voltage 
13 Coin cell battery voltage 
14 Board input voltage (J7) 
15 TPS60310 (U4) output voltage 2 
16 TPS60212 (U2) output voltage 
17 VeREF+ 
18 VREF- 
19 VREF+ 
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20 TPS60212 (U2) LBI 
21 TPS60212 (U2) LBO 
22 BLMSPF2 (J12) BLTGTSIG 
23 MSP430 (U6) VCC 
24 MSP430 (U6) RST/NMI 
25 SST25VF020 (U5) /HOLD 
26 SST25VF020 (U5) /WP 
27 MSP430 (U6) VR03 

 
 
2.3 Miscellaneous Board Options 
 

 
Figure 2-6 ES449 Miscellaneous Board Options 

 
 

 

Table 2-9 Miscellaneous Board Options 

Component Usage 
C1 
C2 

Optional filter capacitors.  Once populated available baud rate is 
reduced 

C30 
C31 

Optional capacitors on X1 and X3 

C32 
C33 

Optional capacitors on X2 and X4 

R1 Sets default auto-powerdown feature of the MAX3221 (U1).  Change as 
needed to implement other power features. See section 4. 
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R2 Sets default auto-powerdown feature of the MAX3221 (U1).  Change as 
needed to implement other power features. See section 4. 

R3 Sets default auto-powerdown feature of the MAX3221 (U1).  Change as 
needed to implement other power features. See section 4. 

R4 Remove or replace to adjust functionality of the TPS7201 (U3) PG pin 
R5 Remove or replace to adjust functionality of the TPS60310 (U4) 

/SNOOZE pin 
R6 Remove or replace to adjust functionality of the TPS60310 (U4) PG pin 
R7 Remove or replace to adjust functionality of the TPS60212 (U2) LBI pin 
R8 Remove or replace to adjust functionality of the TPS60212 (U2) LBO pin 
R9 Remove or replace to adjust functionality of the TPS60212 (U2) 

/SNOOZE pin 
R12 Remove or replace to adjust functionality of the serial flash memory (U5) 
R13 Remove or replace to adjust functionality of the serial flash memory (U5) 
R19 
R31 

Bootloader port current limiting resistor options.  Change R31 to 1.0k 
before using P1.1 as an output 

R20 Optional pull-down resistor for VREF-/VeREF- 
R21 Optional pull-down resistor for VeREF+ 
R27 Replace to adjust the output voltage of the TPS7201 (U3) 
R30 Remove or replace to adjust functionality of the TPS7201 (U3) /EN pin 
R32 Optional current limiting resistor for P6.0 
R33 Optional current limiting resistor for P1.0 
R34 Optional pull-down resistor for the serial flash memory (U5) /WP pin 
X2 Optional high frequency crystal 
X3 Optional ceramic resonator 
X4 Optional ceramic resonator 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Page 15 of 35 



 ES449 User’s Guide  

3. Power Supplies 
 
The ES449 can be operated from a variety of power supplies, depending on the options 
chosen with jumper J20.  This chapter discusses the most common options.  In all 
cases, MSP current can be isolated and measured via J17. 
 
 
3.1 External Regulated Lab Supply 
 
The ES449 can operate from a regulated 1.8 to 3.6v supply connected at J20.2, .4, .6, 
.8, or .10.  See section 3.7 for details. 
 
 
3.2 External Unregulated Lab Supply 
 
The ES449 can operate from an unregulated external lab supply (3.6v to 6v) by 
connecting it to J8, with J20.1-2 jumpered.  Refer to the ES449 schematics for details.  
Adjusting the value of R27 programs the output voltage of the TPS7201.   
 
 

Table 3-1 TPS7201 Output Voltage Programming Guide 

Divider Resistance Output Voltage (V) 
R27 (kΩ)* R28 (kΩ)* 

1.8 88.7 169 
2.0 118 169 
2.7 215 169 
3.0 261 169 
3.3 301 169 
3.6 348 169 

*1% values shown 
 
 
3.3 External Wallmount Supply 
 
The ES449 can be operated from an external wallmount supply via the TPS7201 LDO 
by connecting it to J7 and jumpering J20.1-2.  The power connector is a 2.1 mm barrel 
connector: 
 

 
Figure 3-1 DC Power Connector 

 
The board has a 1W zener diode (D6) to protect the on-board voltage regulators against 
power fluctuations.  Please note that most wall-mount power supplies have voltage 
ratings based on maximum load.  It is important to obtain a power supply with an open 
circuit voltage no greater than 4-6 volts.  The SB6V power supply is recommended. 
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3.4 Single-Cell with Capacitive Charge-Pump 
 
The ES449 can be operated with a single alkaline cell by use of the TPS60310 
capacitive charge-pump with J18.1-2 jumpered and J20.3-4 jumpered.  B2 is an AAA 
socket provided for your convenience.  Battery current can be measured through J18.  
The capacitive charge pump can be disabled via TP9.  A power good flag is available at 
TP10.  See the TPS60310 datasheet for more details.   
 
If desired, a coin cell backup can be used in conjunction with this supply through D7 by 
jumpering J20.9-10.  When the TPS60310 is disabled, unregulated coin cell power will 
continue to supply the ES449. 
 
 
3.5 Unregulated Single-Cell Supply 
 
The ES449 can be operated with a single 3v lithium coin cell by jumpering J20.7-8.  B1 
is a CR2032 socket provided for your convenience. 
 
 
3.6 Regulated Single Cell Supply with Capacitive Charge Pump 
 
The ES449 can be operated with a fixed 3.3v output from the coin cell using the 
TPS60212 charge pump by jumpering J19.1-2 and jumpering J20.5-6.  This charge 
pump can be controlled via TP8 if desired.  Battery current to the regulator can be 
measured through J19. 
 
If desired, a coin cell backup can be used in conjunction with this supply through D7 by 
jumpering J17.9-10.  When the TPS60212 is disabled, unregulated coin cell power will 
continue to supply the ES449. 
 
 
3.7 Power Supply Jumper Options J20 

 
LDO 

 
 
 
 
 
 

1 2 
3 4 
5 6 
7 8 
9 10 

 
AAA C/P 

 
 
 
 
 
 

1 2 
3 4 
5 6 
7 8 
9 10
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Coin Cell C/P 

  1 2 
3 4 
5 6 
7 8 
9 10 

 
Coin Cell 

 1 2 
3 4 
5 6 
7 8 
9 10

 
Capacitive C/P with Coin Cell Idle  

1 2 
3 4 
5 6 
7 8 
9 10 

 

Figure 3-2 ES449 Power Supply Jumper Options 
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4. RS232 Interface 
 
To implement a UART with the MSP430F44x requires use of either on-chip hardware 
UART.  Use J21 to connect TX and RX to either UART0 or UART1 on the MSP430F44x.  
Texas Instruments has a variety of software samples for UART communication available 
on their website.  See section 2.1.20 for the communication configuration header jumper 
options. 
 
The header J21 allows normal communication or loopback operation, as shown in the 
schematic, for testing either or both ends of the interface. 
 
The ICL3221 RS232 interface allows operation in a wide variety of modes; refer to the 
datasheet for full details.  The most common modes are discussed in this chapter. 
The header J13 and resistors R1, R2, and R3 configure the ICL3221.   
 
 
4.1 Always On 
 
As originally shipped, the ICL3221 permits operation with the ICL3221 in "always-on" 
mode.  This mode will not provide the greatest power savings, but is the most 
convenient for starting projects:   
 

Table 4-1 RS232 Always On 

Item Condition Remarks 
J13.1 Open 0 if no valid RS232 levels applied from host, 1 if host is connected.
J13.2 Open  
J13.3 Open  
J13.4 Open  
R1 100k  
R2 100k  
R3 100k  
 
 
4.2 Disabled 
 
If communication is not required, the ICL3221 can be disabled in the lowest-power mode 
by using the following settings: 
 

Table 4-2 RS232 Disabled 

Item Condition Remarks 
J13.1 Open N/a 
J13.2 VCC /EN disables receivers when held high 
J13.3 GND /FORCEOFF forces powerdown when held low 
J13.4 Open  
R1 Open  
R2 100k  
R3 Open  
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4.3 Auto Powerdown 
 
The lowest-power mode for RS232 operation is shown below: 
 

Table 4-3 RS232 Auto-Powerdown 

Item Condition Remarks 
J13.1 Open 0 if no valid RS232 levels applied from host, 1 if host is connected.
J13.2 Open  
J13.3 Open  
J13.4 GND Bring FORCEON low allows auto-powerdown mode 
R1 100k  
R2 Open  
R3 100k  
 
 
In this mode, the ICL3221 can wake the processor via J13.1 if a host port is connected.  
The ICL3221 will manage its own power in this mode. 
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5. Bootloader Adapter 
 
The target board is to be connected to the BLMSPF using the 10-pin box header J12.  
The definition of J12 is given below: 
 

Table 5-1 - Target Adapter Signals 

Pin Name Purpose 
1 BSLTX Bootloader TX from the target.  (Note 1) 
2 TCK Bootloader TCK pin.  (Note 2) 
3 BSLRX Bootloader RX from the target. 
4 RST Bootloader RST pin. 
5 GND Ground. 
6 VCC Bootloader VCC supplied to the target.  (Note 2) 
7 TST Bootloader TEST pin.  Not connected. 
8 NC Not connected 
9 BLPWOFF  
10 BLTGTSIG  
 
Refer to the pin marking on the header to orient pin 1. 
 
Note 1:  The BLTX pin will be held high by the BLMSPF during normal operation of the 
target to isolate the host from any non-serial operation of the target’s firmware.  Should 
the target require use of this pin on their processor, a 1k resistor must be placed in 
series between the target connector and the BLTX pin on the target and all target 
circuitry connected on the target side of the series resistor. 
 
Note 2:  The BLMSPF can supply up to 200mA to the target board.  This supply is cycled 
during bootloader access and target resets to ensure a complete reset of the target.  
This power cycling ensures that firmware using the RST/NMI pin in NMI can still be 
reset. 
 
 
IMPORTANT:  Your project may require incidental use of the BSLTX (P1.1) and BSLRX 
(P2.2) pins.  If so, attempt to configure these pins as outputs so external devices will not 
drive them during bootloading.   
 
IMPORTANT:  If your project reconfigures the RST/NMI pin, bootloader operations 
require that the ES449 be powered from the bootloader.  Remove J12 during 
bootloading to ensure the BLMSPF can seize the MSP. 
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6. SBLCDA2/T LCD Display 
 

 
Figure 6-1 SBLCDA2/T 

 
 
6.1 Overview: 
 
Our advanced SBLCDA2 and SBLCDA2T are compatible with all MSP430F44x devices.  
The SBLCDA2 is for daytime use only while the SBLCDA2T is transflective, which allows 
a backlight to be installed for optional nighttime use.  These two LCDs offer the 
following: 
 

• 2.7v to 3.6v operation directly connected to the MSP430 LCD drive 
• 4-mux operation 
• Seven 14-segment digits with plus/minus symbology allows versatile text 
• Supplemental 4-digit 7-segment clock-counter display 
• Arrows left, up, right, and down 
• Battery with 3-segment meter 
• Antenna with 3-segment meter 
• Colons for HH:MM:SS operation 
• Progress bar for convenient user feedback 
• 6 o’clock viewing angle 
• Low-cost bias circuit allows adjustment for viewing angle, contrast, and 

temperature 
• Transflective option allows for the addition of a backlight for nighttime viewing 

(SBLCDA2T only)  
• Operating temperature –20C/50C  
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6.2 Typical Operation: 
 
The following graphs illustrate the SBLCDA2 and SBLCDA2Ts viewing angles for the 
range of VCC from 2.7v to 3.6v.  The voltage was measured on pin 56 (R03) of the 
MSP430F449.  This is the input port of the lowest analog LCD level (V5).  The voltage is 
controlled by P2 on our ES449 development kit and can be measured at TP27. 
 

 
Figure 6-2 SBLCDA2 Contrast Adjustment--Daytime 

 
 

 
Figure 6-3 SBLCDA2T Contrast Adjustment--Daytime 
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Figure 6-4 SBLCDA2T Contrast Adjustment--Backlit 
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6.3 SBLCDA2 Segment Mapping 
 
PIN COM3 COM2 COM1 COM0  COM3 COM2 COM1 COM0 PIN 
1 1A 1B 1C 1D  COM3    48 
2 1J 1K 1M 1N   COM2   47 
3 2COL 2F 2E 1DP    COM1  46 
4 2H 2G 2Q 2P     COM0 45 
5 2A 2B 2C 2D  1H 1G 1Q 1P 44 
6 2J 2K 2M 2N  PLUS 1F 1E MINUS 43 
7 3COL 3F 3E 2DP  A1 A2 ANT A0 42 
8 3H 3G 3Q 3P  PL P0 P1 P2 41 
9 3A 3B 3C 3D  P6 P5 P4 P3 40 
10 3J 3K 3M 3N  NC NC NC NC 39 
11 4COL 4F 4E 3DP  NC NC NC NC 38 
12 4H 4G 4Q 4P  P7 P8 P9 PR 37 
13 4A 4B 4C 4D  B0 B1 B2 BRBL 36 
14 4J 4K 4M 4N  AD AR AU AL 35 
15 5COL 5F 5E 4DP  8D 8E 8G 8F 34 
16 5H 5G 5Q 5P  8DP 8C 8B 8A 33 
17 5A 5B 5C 5D  9D 9E 9G 9F 32 
18 5J 5K 5M 5N  10DP 9C 9B 9A 31 
19 6COL 6F 6E 5DP  10COL 10E 10F 10A 30 
20 6H 6G 6Q 6P  10D 10C 10G 10B 29 
21 6A 6B 6C 6D  11DP 11E 11F 11A 28 
22 6J 6K 6M 6N  11D 11C 11G 11B 27 
23 SB 7F 7E 6DP  7J 7K 7M 7N 26 
24 7H 7G 7Q 7P  7A 7B 7C 7D 25 
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6.4 ES449 Segment Mapping 

 

MEM BIT7 BIT6 BIT5 BIT4 BIT3 BIT2 BIT1 BIT0  
*LCDM1 A1 A2 ANT A0 0 0 0 0 *S1:S0 
LCDM2 AD AR AU AL B0 B1 B2 BRBL S3:S2 
LCDM3 11DP 11E 11F 11A 11D 11C 11G 11B S5:S4 
LCDM4 10COL 10E 10F 10A 10D 10C 10G 10B S7:S6 
LCDM5 9D 9E 9G 9F 10DP 9C 9B 9A S9:S8 
LCDM6 8D 8E 8G 8F 8DP 8C 8B 8A S11:S10 
**LCDM7         **S13:S12--See below
**LCDM8         **S15:S14--See below
LCDM9 6A 6B 6C 6D 6J 6K 6M 6N S17:S16 
LCDM10 6COL 6F 6E 5DP 6H 6G 6Q 6P S19:S18 
LCDM11 5A 5B 5C 5D 5J 5K 5M 5N S21:S20 
LCDM12 5COL 5F 5E 4DP 5H 5G 5Q 5P S23:S22 
LCDM13 4A 4B 4C 4D 4J 4K 4M 4N S25:S24 
LCDM14 4COL 4F 4E 3DP 4H 4G 4Q 4P S27:S26 
LCDM15 3A 3B 3C 3D 3J 3K 3M 3N S29:S28 
LCDM16 3COL 3F 3E 2DP 3H 3G 3Q 3P S31:S30 
LCDM17 2A 2B 2C 2D 2J 2K 2M 2N S33:S32 
LCDM18 2COL 2F 2E 1DP 2H 2G 2Q 2P S35:S34 
LCDM19 1A 1B 1C 1D 1J 1K 1M 1N S37:S36 
LCDM20 PLUS 1F 1E MINUS 1H 1G 1Q 1P S39:S38 
**Progress Bar 
Option         
LCDM7 P6 P5 P4 P3 P7 P8 P9 PR S13:S12 
LCDM8 SB 7F 7E 6DP PL P0 P1 P2 S15:S14 
**Seventh Digit 
Option         
LCDM7 7A 7B 7C 7D 7J 7K 7M 7N S13:S12 
LCDM8 SB 7F 7E 6DP 7H 7G 7Q 7P S15:S14 
          
*Note: Always set LCDM1 lower nibble (S0) to 00h to disable 
unused segments    
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1.100" /
27.94mm

0.028" /
0.71mm

x48

0.0787" /
2.00mm

Recommended SBLCDA2 Footprint
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7. Software Development Tools 
 
The ES449 is compatible with all third-party MSP430 development tools.  The software 
development tools we recommend are: 
 
Rowley Associates CrossWorks for MSP430 
Quadravox AQ430 for MSP430 
 
In this section, we provide instructions for installing each of these tools and preparing for 
work with the ES449. 
 
7.1 Quadravox AQ430 for MSP430 
 
Quadravox offers three different software development tools for the MSP430F449.  First, 
they offer a free 30-day trial version that has a code limit of 4kB. Next, they offer a full-
version compiler that is only compatible with the MSP430F44x family of microcontrollers.  
Lastly, they offer a full-version software development tool that works with the entire 
MSP430 family and has no code limit.     
 
 
7.1.1 Download 
 

1. To download the free version of AQ430 from quadravox go to their website at 
www.quadravox.com.   

 
2. Click on the ‘download free 30 day trial version’ link.  Select your operating 

system and click on ‘Download.’   
 

3. Save this file onto your hard drive.  Note the folder you are downloading the file 
into.   

 
 
7.1.2 Installation 
 

1. First open the folder containing the AQ430x.exe file you previously downloaded.  
Open the AQ430x.exe program by double-clicking the icon.   

 
2. A WinZip self-extractor window should appear, now select ‘Setup’.   

 
3. Once the files have been unzipped you will need to select ‘Next’ four times.   

 
4. Once the files have been installed the installation wizard will ask you to restart 

the program at this time, go ahead and restart.  
 

5. Open Quadravox AQ430 by selecting Start>Programs>qvarch430tools. 
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7.1.3 Full Version 
 
To obtain the full version you can purchase a registration key from SoftBaugh.  This 
should be sent to Quadravox along with the challenge string from the 30-day trial version 
software.  You can find the challenge string by opening the AQ430 program and 
selecting ‘Buy.’  
 
 
7.2 Rowley Associates CrossWorks for MSP430 
 
Rowley offers two different software development tools for the MSP430F449.  First, they 
offer a free 30-day full-version that has no code limit.  They also offer a full-version 
software development tool that works with the entire MSP430 family and has no code 
limit.     
 
 
7.2.1 Download 
 

1. To download the free trial version of CrossWorks go to their website at 
www.rowley.co.uk. 

   
2. Under the heading ‘CrossWorks 1.0 is here’ select the link.  On the next page 

select the link ‘Download CrossWorks for MSP430 1.0 Zip File’ at the bottom of 
the page. 

 
3. Save this file onto your hard drive.  Note the folder you are downloading the file 

to.   
 

4. Once you have downloaded a copy of CrossWorks you will need to get an 
activation key from them by emailing them the registration key that the installer 
provides to license@rowley.co.uk.   You will be prompted to do this during the 
installation process. 

 
 
7.2.2 Installation 
 

1. First open the folder containing the msp430_1_0_0.zip file you previously 
downloaded.  Open the msp430_1_0_0.zip file by double-clicking the icon.   

 
2. Scroll down and double-click on the setup.exe file.   

 
3. Double-click on ‘Next.’  Read Rowley’s license agreement and accept it by 

selecting the corresponding box.  Then select ‘Next.’   
 

4. On the next screen insert a checkmark into the box next to the statement ‘Set 
license up manually after installation has completed,’ then select ‘Next.’   

 
5. Select ‘Next’ five more times.   
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6. Lastly select ‘Install’ on the last window.  The file installation will begin at this 
time.  Once the installation is completed, restart your computer.   

 
7. Open Rowley CrossWorks by selecting Start>Programs>Rowley Associates 

Limited>CrossWorks MSP430 1.0.0>CrossStudio.   
 

8. Select the ‘Help’ menu then select ‘About CrossStudio.’  A window will appear, 
now select the ‘Product Activation’ tab.  

 
9. You should see the registration key.  You need to email the registration key to 

license@rowley.co.uk they will send the activation key back to you that needs 
to be entered into the activation key field directly below the registration key field. 

 
 
7.2.3 Full Version 
 
To obtain the full version you can purchase the activation key from SoftBaugh.  The 
registration key of your trial version can be sent to keys@softbaugh.com.  SoftBaugh will 
process your registration key and return a full version activation key that will replace the 
current activation key. 
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8. Lab One, MSP430 JTAG Debugging 
 
Once your software development tools are installed, you can begin enjoying the benefits 
of your ES449.  If you haven't yet selected and installed your development tools, please 
flip back to the previous chapter.  
 
In this chapter, we work through a simple demonstration program called ES449_Jenny, 
available for download from our website. 
 
This chapter presents the first laboratory exercise available in the ES449 Laboratory 
Manual available for purchase separately on our website.  The laboratory manual is 
available in two versions, one for Quadravox (LMES449Q) and one for CrossWorks 
(LMES449CW). 
 
 
8.1 Step One, Organize Your Materials 
 
For this laboratory exercise, you will need the following: 
 
- ES449 Evaluation System 
- SoftBaugh FETP JTAG programmer, or equivalent. 
- 14-pin cable supplied with the JTAG programmer. 
- 25-pin straight-through parallel port extension cable.  Available at most PC outlets. 
- Installed Quadravox or CrossWorks software development tools on a compatible PC. 
 
 
8.2 Step Two, Connect the JTAG Programmer 
 
To program and debug your ES449, the JTAG programmer must be connected.  These 
instructions assume you are using a SoftBaugh FETP JTAG programmer, but other 
equivalent devices may be used.  Warning:  If you have a new, very fast, or "green" PC, 
you may have difficulty with equivalent JTAG programmers on any MSP430 target.  
Obtaining a genuine SoftBaugh FETP will usually resolve these problems (as of this 
writing, we haven't seen a case where it hasn't yet!). 
 
Connect FETP:J1 to your PC's parallel port using the 25-pin parallel extension cable.  
Then, connect FETP:J2 to ES449:J11 using the 14-pin JTAG cable. 
 
For this exercise, the jumper options will be in the following configuration: 
 

Using the 6v lab power supply jumper J20.1-2 and J17.1-2. 
 

Using the AAA battery supply jumper J20.3-4, J17.1-2, and J18.1-2. 
 

Using the coin cell battery supply jumper J20.5-6, J17.1-2, and J19.1-2. 
 
Also J23 will need to be jumpered as follows: J23.1-2, 4-5, 7-8, 11-12, 14-15, 17-18. 
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8.3 Rowley CrossWorks 
 

Note:  If you are using Quadravox skip to section 8.4. 
 
 
8.3.1 Step Three, Open the Sample Project 
 

1. You will first need to download the Jenny project file from our internet site at 
www.softbaugh.com/OuterES449.shtml.  The download is referenced as ES449 
Jenny Demo for CrossWorks.  Save this .zip file to your computer. 

 
2. Open Rowley CrossWorks by selecting Start>Programs>Rowley Associates 

Limited>CrossWorks MSP430 1.0.0>CrossStudio. 
 

3. After the program opens, select File>Open Solution. 
 

4. Now open the file ES449_Jenny.hzp.  Note: if you cannot see this file in the 
folder you placed it, you may need to extract the file out of the .zip file previously 
downloaded. 

 
 
8.3.2 Step Four, Build the Code 
 

5. Select Project>Build Solution in the upper taskbar. 
 
6. In the build log at the bottom of the screen it should now say build complete. 

 
 
8.3.3 Step Five, Program the Target 
 

7. To program the target first select Target>Connect MSP 430 FET in the upper 
taskbar.  This connects the debugger to the flash emulation tool. 

 
8. In the ‘Targets’ window on the right side of the screen you should see a red 

check mark next to the MSP430 FET indicating it is connected.  Note: if you do 
not see the red check make sure the JTAG connectors are fastened securely and 
try again.  See section 8.2. 

 
 
8.3.4 Step Six, Execute the Code 
 

9. Select Debug>Start Debugging to begin executing code. 
 
10. After a few seconds the LCD on the ES449 should become active.   

 
 
8.3.5 Step Seven, Debug the Code 
 

11. Select Debug>Break to stop executing code. 
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12. The source code file will automatically open in the main window and a yellow 
arrow indicates where the code was halted.  You should also notice the LCD on 
the ES449 is steady. 

 
13. Press F11, this is the ‘Step Into’ function.  Each time it is pressed one line of 

code is executed.  “Stepping” is useful for tracing the flow of your code. 
 

14. Press F5, this is the ‘Go’ function.  When pressed the code will be executed 
continuously until a breakpoint halts it or until you select Debug>Break or 
Debug>Stop. 

 
15. Breakpoints are useful when debugging your code.  After a breakpoint is set to a 

line of code the debugger will execute the code until it reaches the breakpoint.  
Once the breakpoint is reached the execution of code will halt on the breakpoint.  
From there you can step through the code to ensure the proper flow.   

 
16. Set a breakpoint on the following statement by clicking on the small blue arrow 

next to this line of code:   
 

xor.b #001h,&P1OUT    ; Toggle LED 
 

 This line of code is located on line 90 approximately of the ES449_Jenny.asm 
file, almost half way down.  

 
17. Once the breakpoint is set a red dot should replace the blue arrow next to that 

line of code only. 
 
18. Now each time you press F5 or Debug>Go, the code will run to this breakpoint 

and the LED D1 will toggle off and on. 
 
 
8.4 Quadravox 
 
 
8.4.1 Step Three, Open the Sample Project 
 

1. You will first need to download the Jenny project file from our internet site at 
www.softbaugh.com/OuterES449.shtml.  The download is referenced as ES449 
Jenny Demo for Quadravox.  Save this .zip file to your computer. 
 

2. Open Quadravox AQ430 by selecting Start>Programs>qvarch430tools. 
 

3. After the program opens, select Project>Open. 
 

4. Now open the file ES449_Jenny.qpj.  Note: if you cannot see this file in the folder 
you placed it, you may need to extract the file out of the .zip file previously 
downloaded. 
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8.4.2 Step Four, Build the Code and Program the Target 
 

5. Select Build>Rebuild All. 
 

6. A couple of windows will now open including a window showing the source code.  
A yellow arrow indicates the next line of code to be executed. 

 
7. Your target should now be programmed and ready to execute code. 

 
 
8.4.3 Step Five, Execute the Code 
 

8. Select Debug>Go to begin executing code. 
 

9. After a few seconds the LCD on the ES449 should become active. 
 
 
8.4.4 Step Six, Debug the Code 
 

10. Select Debug>Stop to stop executing code 
 

11. Press F7, this is the ‘Step’ function.  Each time it is pressed one line of code is 
executed.  “Stepping” is useful for tracing the flow of your code. 

 
12. Now press F9, this is the ‘Go’ function.  When pressed the code will be executed 

in real time. 
 

13. Breakpoints are useful when debugging your code.  After a breakpoint is set to a 
line of code the debugger will execute the code until it reaches the breakpoint.  
Once the breakpoint is reached the execution of code will halt on the breakpoint.  
From there you can step through the code to ensure the proper flow.   

 
14. Set a breakpoint on the following statement by right-clicking on it and selecting 

‘Toggle BP.’ 
 
   xor.b #001h,&P1OUT    ; Toggle LED 
 

This line of code is located on line 130 approximately of the ES449_Jenny.asm 
file, almost half way down.  

 
15. Once the breakpoint is set that particular line of code will be highlighted red. 
 
16. Now each time you press F9 or Debug>Go the code will run to this breakpoint 

and the LED D1 will toggle off and on. 
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